Back to overview
Degraded
ping platform.thebirdling.com is down
Oct 05 at 01:02am CET
Affected services
ARG🅞S™
Resolved
Oct 05 at 01:07am CET
ping platform.thebirdling.com recovered.
Affected services
Created
Oct 05 at 01:02am CET
ping platform.thebirdling.com is degraded.
Affected services