Back to overview
Degraded

ARG🅞S™ is down

Oct 22 at 04:22pm CET
Affected services
ARG🅞S™

Resolved
Oct 22 at 04:30pm CET

ARG🅞S™ recovered.

Created
Oct 22 at 04:22pm CET

ARG🅞S™ is degraded.